Discussion Forum

Open schema in grakn console

Hi,
I’m new to grakn and I’m following the social network example in the following link.
https://dev.grakn.ai/docs/general/quickstart
I followed the steps in the webpage but I couldn’t load the schema into grakn console.
I’m attaching a screenshot of the terminal with this for your reference.
Picture1

Can you try it without the quotes please?

when I try this without the quotes I get an error message as this
←[31mFailed to open file 'C:UsersyasitDesktopGrakndata.gql’←[0m

Interesting!! We don’t do a lot of testing on windows, so this is relatively new to us.

It looks like we’re losing your \ characters as these are treated as escape characters…

can you try using double \? This way you escape the escape character :smiley:

eg. C:\\\\User\\syasit\\Desktop\\Grakn\\data.gql

got mine to work using / instead of \ and no quotes and no spaces in the name. Yes before anyone says it this is windows and it is only natural to expect to use \ in a file path

Yeah windows should use \, but its not unnatural to escape backslashes either - have you tried using \\ everywhere \ was before?

Thank you very much for your responses. I tried both, using / and double \ mark. Both worked and I was able to load the schema to the console.

1 Like