Discussion Forum

Old attributes showing in Workbase

I can’t figure out why attributes from an old schema are showing up. I’ve cleared the DB, reinstalled 1.4.2 (via brew), reinstalled Workbase, restarted my computer and tried playing with different words in my model thinking that perhaps something was reserved. When I match for my entity “keywords” in Workbase it shows attributes for “content” and “text”, which are no longer attributes I’m using! The only attribute I’m setting is “hashtag”. “Content” and “text” aren’t even listed in the attributes. This seems like a weird cache issue, but I don’t understand where the problem could live that wouldn’t be solved by all the resetting I’ve done.

This is my model:


source sub entity
  has title
  has authors
  plays data;

annotation sub source
  has body;

keyword sub entity
  has hashtag
  plays topic;

title sub attribute datatype string;
authors sub attribute datatype string;
body sub attribute datatype string;
hashtag sub attribute datatype string;

connection sub relationship
  relates data
  relates topic;

It works fine in the browser, but I believe that might have been because I found the “reset label” feature by clicking and holding on the node. Thanks for your help,

Hi @mattgaidica,

I believe these attribute labels are stored in your workbase config file. We will be adding a feature to manage your configurations in workbase. Until then you will need to manually remove the config file by doing the following:

  1. cd ~/Library/Application\ Support/grakn-workbase/
  2. rm config.json
  3. restart workbase

That was it! Thank you much

1 Like