Discussion Forum

Mac Install Error - "Calling depends_on :java is disabled!"

Apologies for a newbie question. I’m a student and just getting started with Grakn and CS generally.

I’m trying to install Grakn using Homebrew following the directions in the tutorial and get the following error message:

==> Tapping graknlabs/tap

Error: Invalid formula: /usr/local/Homebrew/Library/Taps/graknlabs/homebrew-tap/Formula/grakn-core.rb

grakn-core: Calling depends_on :java is disabled! Use "depends_on “openjdk@11”, "depends_on “openjdk@8” or "depends_on “openjdk” instead.

Please report this issue to the graknlabs/tap tap (not Homebrew/brew or Homebrew/core), or even better, submit a PR to fix it:

/usr/local/Homebrew/Library/Taps/graknlabs/homebrew-tap/Formula/grakn-core.rb:9

Error: Cannot tap graknlabs/tap: invalid syntax in tap!

Prior to attempting to install Grakn, I downloaded and installed Java 8. When I type javac - version at the command line, I get: javac 1.8.0_271

Any help getting started would be greatly appreciated! Thanks.