Discussion Forum

Install issue - Win10

Hello. Newbie here. Trying to install on Win10.

Have updated Java:
java version “1.8.0_311”
Java™ SE Runtime Environment (build 1.8.0_311-b11)
Java HotSpot™ Client VM (build 25.311-b11, mixed mode)

Not clear how to use typedb.bat (if at all?) - when running from Powershell get the following:
Missing argument. Possible commands are:
Server: typedb server [–help]
Cluster: typedb cluster [–help]
Console: typedb console [–help]

When running “,\typedb server” get the following error:
Error: A JNI error has occurred, please check your installation and try again
Exception in thread “main” java.lang.UnsupportedClassVersionError: com/vaticle/typedb/core/server/TypeDBServer has been compiled by a more recent version of the Java Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0

Any advice to achieve install is gratefully appreciated.

Thanks

Ah OK. JDK 17 has a 55+ class compiler.